Erreur Atlas : Atlas.lua:380: bad argument #1 to 'lower' (string expected, got nil)

Voir le sujet précédent Voir le sujet suivant Aller en bas

Erreur Atlas : Atlas.lua:380: bad argument #1 to 'lower' (string expected, got nil)

Message  Invité le Ven 1 Aoû - 10:44

PROBLEME

Depuis l'installation du dernier patch (2.4.3), j'ai des erreurs Atlas après le chargement de tous mes personnages. L'erreur est la suivante :
Atlas.lua:380: bad argument #1 to 'lower' (string expected, got nil)

J'ai la dernière version d'Atlas (1.12.0). En plus d'être ennuyant au moment de la connexion, cette erreur crée des problèmes dans la liste des instances. Certaines instances sont listée avec une ligne vide, et une erreur apparaît lorsqu'on les sélectionne.

CAUSE

Le format de nommage des villes et instances a été changé dans WoW récemment et Atlas a été modifié en conséquence. Tous les addons qui n'auraient pas été mis à jour s'exposent à un problème.
Un des modules des vieilles versions d'Atlas est dans ce cas de figure. Il n'est plus utilisé/distribué et n'a donc jamais été mis à jour. Si vous installez Atlas en copiant la nouvelle version dans \World of Warcraft\Interface\AddOns, il se peut que l'ancien module n'ait jamais été supprimé.

SOLUTION

Option 1 - Supprimer \World of Warcraft\Interface\AddOns\Atlas_Entrances (ancien module obsolète)
Option 2 - Supprimer tous les répertoires Atlas* de vos addons, puis réinstaller Atlas (et variantes)

Invité
Invité


Revenir en haut Aller en bas

Voir le sujet précédent Voir le sujet suivant Revenir en haut

- Sujets similaires

 
Permission de ce forum:
Vous ne pouvez pas répondre aux sujets dans ce forum